Synapse Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Feb 13, 2021 - 02:37 UTC
Investigating
We're investigating an issue with the Synapse funding method. Deposits and withdrawals are currently delayed. We will provide any updates as soon as possible.
Posted Feb 11, 2021 - 17:06 UTC
This incident affected: Fiat Currency Funding (US Dollar (USD) - Domestic).