RTP Withdrawals Experiencing Delays

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Apr 17, 2026 - 17:44 UTC

Investigating

Some clients may be experiencing delays when processing RTP withdrawals through Plaid US. We are currently investigating the cause and working to restore normal processing times. We will continue to provide updates as more information becomes available.
Posted Apr 17, 2026 - 15:20 UTC