EOS Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jun 26, 2021 - 17:58 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 26, 2021 - 15:48 UTC
Investigating
EOS withdrawals are being delayed. We will provide updates as as soon as there are any changes.
Posted Jun 26, 2021 - 12:08 UTC
This incident affected: Digital Currency Funding (EOS (EOS)).