Issues Completing Business Onboarding

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 20:14 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 26, 2025 - 19:39 UTC

Investigating

We are currently investigating an issue affecting some users attempting to complete business onboarding. Affected users may experience a blank screen or be unable to proceed after uploading required documents.

Our teams are actively working to identify the cause and restore full functionality as quickly as possible. We will provide further updates as soon as more information becomes available.
Posted Nov 26, 2025 - 19:23 UTC