Delay Crediting Plaid EUR Deposits for Newly Registered Clients

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jul 15, 2025 - 20:07 UTC

Identified

We are currently investigating a delay affecting the crediting of EUR Easy Bank Transfer deposits via Plaid to personal accounts created after 7:30 UTC on July 14. We have disabled the Easy Bank Transfer method until the issue will be resolved. Please feel free to initiate deposits via Manual bank transfers, since manual bank transfers are processed normally. This issue does not affect GBP Easy Bank deposits, EUR Easy Bank deposits to clients who joined before that time or any corporate accounts.

Our team is actively working to resolve this issue, and we will provide further updates as they become available.
Posted Jul 15, 2025 - 13:11 UTC