Etana Custody Funding Issue
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Apr 21, 2020 - 19:58 UTC
Investigating
We're investigating an issue with the Etana Custody funding gateway. Deposits and withdrawals are currently unavailable. We will provide any updates as soon as possible.
Posted Apr 21, 2020 - 12:12 UTC
This incident affected: Fiat Currency Funding (Etana Custody).