Silvergate Exchange Network (SEN) Withdrawal Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Apr 26, 2021 - 16:54 UTC
Investigating
We are investigating an issue with USD withdrawals (domestic & international) through Silvergate Exchange Network (SEN). Withdrawals are currently delayed. We will provide any updates as soon as possible.
Posted Apr 26, 2021 - 14:01 UTC
This incident affected: Fiat Currency Funding (US Dollar (USD) - Domestic, US Dollar (USD) - International).