Euro (EUR) SEPA Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted 2 months ago. May 14, 2019 - 16:10 UTC
Monitoring
The delays in crediting Euro (EUR) SEPA deposits to clients' trade balances have returned to normal. We will continue monitoring the situation closely.
Posted 2 months ago. May 14, 2019 - 13:11 UTC
Update
The delays in crediting Euro (EUR) SEPA deposits to clients' trade balances have returned to normal. We will continue monitoring the situation closely.
Posted 2 months ago. May 14, 2019 - 13:10 UTC
Investigating
We are currently experiencing delays with crediting Euro (EUR) SEPA deposits to clients' trade balances. We are investigating the issue and will update as soon as we have further information.
Posted 2 months ago. May 14, 2019 - 08:50 UTC
This incident affected: Fiat Currency Funding (Euro (EUR) - SEPA).