Banking Circle Funding Delays

Incident Report for Kraken

Resolved

Issue with the Banking Circle funding gateway has been resolved. Deposits and withdrawals through Banking Circle are being processed correctly.
Posted Apr 03, 2025 - 11:11 UTC

Investigating

We have identified an issue with the Banking Circle funding gateway. Deposits and withdrawals through Banking Circle may be delayed at this time. We are working diligently to resolve the issue and will keep you updated.
Posted Apr 03, 2025 - 02:36 UTC