Krak App - Adding a Withdrawal Address Issue

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Aug 06, 2026 - 11:08 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 06, 2026 - 08:48 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 06, 2026 - 07:41 UTC

Investigating

We are investigating an issue where the withdrawal address confirmation link when adding a withdrawal address on Krak App does not work. The workaround is try with another platform, such as the Kraken Pro app or the Kraken app.

Our teams are reviewing the issue and working to understand the scope of impact. We will provide another update as soon as more information is available.
Posted Aug 06, 2026 - 06:24 UTC