New Account Verification Delays

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Dec 08, 2025 - 12:19 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 08, 2025 - 10:02 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 08, 2025 - 09:54 UTC

Investigating

We are currently investigating an issue causing delays for users who are creating a new Kraken account.

After submitting information or documents, some users may notice that their account verification status does not update. No action is needed at this time - once the issue is resolved, affected account applications will continue processing automatically.

Further updates will be provided as soon as more information becomes available.
Posted Dec 08, 2025 - 08:56 UTC