Fidor (EUR) Deposit Delays
Incident Report for Kraken
Resolved
The incident has been resolved, and deposit times have returned to normal.
Posted 3 months ago. Apr 05, 2019 - 12:35 UTC
Investigating
We are currently experiencing issues processing some SEPA EUR deposits via Fidor. Delays in processing are expected. We are investigating the issue and will update as soon as we have further information.
Posted 3 months ago. Apr 05, 2019 - 10:37 UTC
This incident affected: Fiat Currency Funding (Euro (EUR) - SEPA).