Connectivity Issues - Historical Balance & Transactions Display Issue Across Multiple Platforms

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 09:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2026 - 09:24 UTC

Investigating

We are investigating an issue affecting historical balances and transaction visibility across multiple platforms. Clients may experience errors or increased latency when attempting to view historical balances, and newly completed transactions may appear with a delay. We are working to restore normal performance.
Posted Apr 21, 2026 - 08:48 UTC
This incident affected: Website and Kraken App.