Intermittent CAD Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted May 20, 2023 - 21:27 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 20, 2023 - 16:14 UTC
Investigating
We are investigating reports that some clients are experiencing funding delays. This can result in delayed deposits, withdrawals for some corporate clients using CAD. We are currently investigating the issue and are working towards a solution. We will provide any updates as soon as possible.
Posted May 20, 2023 - 16:13 UTC