Email Delivery Issues
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Nov 11, 2020 - 19:30 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 11, 2020 - 17:52 UTC
Investigating
We are currently experiencing email delivery issues. We have identified the problem and are currently working to resolve the issue as soon as possible.

Note: If you are experiencing an issue with authorizing a new device, please use a device you have previously approved, if possible to access your account.
Posted Nov 11, 2020 - 17:50 UTC