Domestic US Dollar (USD) Funding Delays
Incident Report for Kraken
Resolved
Issues with domestic USD deposits, withdrawals and user activations have been resolved. Our domestic USD funding gateway is now fully functional. Please contact our support team if you encounter any further issues.
Posted Apr 22, 2020 - 20:24 UTC
Investigating
We are currently experiencing delays with domestic US Dollar (USD) deposits and withdrawals as well as related new user activations. We are investigating the issue with our funding partner and will provide any update as soon as we have further information.
Posted Apr 22, 2020 - 15:30 UTC
This incident affected: Fiat Currency Funding (US Dollar (USD) - Domestic).