Disruption to EFT Withdrawals and In-Person Payments in Canada

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jun 30, 2025 - 19:49 UTC

Identified

We are currently aware of an issue affecting EFT withdrawals and in-person payment processing in Canada. Clients may be unable to complete withdrawals using these methods at this time.

We will provide an update as soon as more information becomes available. We apologize for the inconvenience and appreciate your patience.
Posted Jun 30, 2025 - 19:10 UTC
This incident affected: Payment Methods (Canadian Dollar (CAD) - Domestic).