Moonbeam deposits and withdrawals disabled
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Aug 02, 2022 - 04:40 UTC
Monitoring
Moonbeam maintenance has been completed and currently monitoring.
Posted Aug 02, 2022 - 03:55 UTC
Identified
Moonbeam is currently having maintenance work being done.
Posted Aug 02, 2022 - 01:45 UTC
This incident affected: Digital Currency Funding (Moonbeam (GLMR)).