Email delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Dec 20, 2024 - 12:19 UTC
Identified
We have identified small delays for clients on the reception of certain Email Communication, such as Activation, Log in emails, and also including spamming on these notifications. We are working to resolve the issue and will update as soon as we have more information.
Posted Dec 20, 2024 - 11:58 UTC
This incident affected: Support.