US Visa Purchases and Recurring Buys Unavailable
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 23:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 12, 2024 - 22:13 UTC
Investigating
We are currently investigating an incident which impacts US Visa purchases and recurring buys. We will provide more information as we are able.
Posted Apr 12, 2024 - 21:02 UTC