Portfolio Transaction History slow to load or unavailable

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted May 10, 2025 - 01:10 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 09, 2025 - 22:38 UTC

Investigating

We are currently investigating an issue affecting transaction history views for Portfolio on Web and Mobile platforms.
Some users may encounter errors when attempting to view individual transaction details. Mobile apps may also display missing blockchain explorer data.

We are actively reviewing the issue. We will provide further updates as soon as more information is available.
Posted May 09, 2025 - 22:08 UTC
This incident affected: Website and Mobile Applications.