Balance Display Issues

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted May 26, 2021 - 03:18 UTC

Monitoring

A fix has been implemented and we are now monitoring the results.
Posted May 26, 2021 - 02:29 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 26, 2021 - 02:18 UTC

Investigating

Some clients have reported currency values reflecting incorrectly in trade balances. We are currently investigating the issue.
Posted May 26, 2021 - 01:44 UTC