TGBP Unavailable on Instant Buy/Sell (Mobile & Web)

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted May 03, 2026 - 05:20 UTC

Investigating

TGBP is currently unavailable on Instant Buy/Sell (Kraken App & Buy Crypto on Web). We are working on a fix and will update as soon as we have more information. In the meantime, please use the Kraken Pro App or the trade order form on pro.kraken.com.
Posted May 02, 2026 - 10:24 UTC