Krak Card Transaction Failures

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Dec 18, 2025 - 10:02 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 18, 2025 - 09:26 UTC

Investigating

We are investigating an issue causing Krak card transactions to fail. Users may be unable to complete card transactions at this time. We are working to resolve the issue and will update as soon as we have more information.
Posted Dec 18, 2025 - 09:07 UTC
This incident affected: Krak Card.