Closed Orders Visibility Issue

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 15:23 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 05, 2025 - 00:13 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 04, 2025 - 14:06 UTC

Identified

Closed orders data for Saturday, August 30 has been successfully remediated. We are continuing work on remediation for the issue preventing clients from viewing orders closed on Thursday, August 28, Friday, August 29 and Monday September, 1. All other order data outside of this date range remains unaffected. We will provide the next update when we have new information.
Posted Sep 02, 2025 - 13:19 UTC

Update

We are continuing to work on remediation for the issue preventing clients from viewing orders closed between Thursday, August 28 and Saturday, August 30. All other order data outside of this date range remains unaffected. We will provide the next update when we have new information.
Posted Sep 01, 2025 - 12:58 UTC

Investigating

We are investigating an issue where clients are unable to view orders closed between Thursday, August 28 and Saturday, August 30. We are working to resolve the issue and will update as soon as we have more information.
Posted Sep 01, 2025 - 08:46 UTC