Bank Frick Deposit Delays

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Nov 23, 2023 - 18:10 UTC

Investigating

We are currently investigating this issue.
Posted Nov 23, 2023 - 16:20 UTC
This incident affected: Payment Methods (US Dollar (USD) - Domestic, US Dollar (USD) - International, Swiss Franc (CHF) - Domestic, Swiss Franc (CHF) - International).