US Dollar (USD) - International CBIT Funding Delays

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Aug 27, 2024 - 14:20 UTC

Identified

We have identified an issue with the US Dollar (USD) - International funding gateway. Deposits and withdrawals through CBIT may be delayed at this time. All other funding methods are operating normally. We are working diligently to resolve the issue and will keep you updated.
Posted Aug 27, 2024 - 13:24 UTC
This incident affected: Payment Methods (US Dollar (USD) - International).