Android App crash when uploading Proof of Address documents

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted May 14, 2025 - 17:21 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 12, 2025 - 14:14 UTC

Investigating

We are currently investigating an issue affecting the latest version of the Kraken Android app (v3.15.0), where the app may crash when users attempt to upload proof-of-address (PoA) documents during onboarding. This issue does not affect ID document uploads, selfie verification, or any iOS app versions.
We are working to resolve the issue and will update as soon as we have more information.
Posted May 12, 2025 - 14:12 UTC
This incident affected: Mobile Applications.