Crypto Withdrawal Delays

Incident Report for Kraken

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2026 - 15:39 UTC

Investigating

We are investigating an issue causing a subset of withdrawals to get delayed.

We are working diligently to resolve the issue and will keep you informed. Thank you for your patience.
Posted Jul 29, 2026 - 15:33 UTC