Verification Processing Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Apr 17, 2021 - 21:38 UTC
Monitoring
As a result of heavy traffic we are experiencing longer than usual verification processing times. We will continue to monitor and will update as soon as possible.
Posted Apr 17, 2021 - 01:14 UTC
This incident affected: Website and Kraken API (REST, WebSockets).