Banking Circle Funding Delays

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Apr 11, 2025 - 06:39 UTC

Identified

We have identified an issue with the € Euro (EUR) Banking Circle funding gateway, which may result in delays to withdrawals for some clients. All other funding methods are operating normally. We are working diligently to resolve the issue and will keep you updated.
Posted Apr 11, 2025 - 02:21 UTC
This incident affected: Payment Methods (Euro (EUR) - Instant, Euro (EUR) - SEPA).