Issue Selecting Country Code During Account Creation on Kraken Website

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 18:16 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 26, 2025 - 17:39 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 26, 2025 - 14:54 UTC

Investigating

We’ve identified an issue where some users on the Kraken website may not be able to select or change the country code when entering their phone number during account creation.

As a workaround, users can complete the process using the Kraken mobile apps, which are not affected by this problem.

We will provide updates as more information becomes available.
Posted Nov 26, 2025 - 13:02 UTC