Temporary Disruption to EUR Funding via BLINC

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Aug 26, 2025 - 17:20 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 26, 2025 - 17:12 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 26, 2025 - 16:30 UTC

Investigating

We are currently investigating an issue impacting EUR deposits and withdrawals via the BLINC method. Clients using this funding route may experience temporary disruption. Our team is actively working on restoring full service.

We will provide further updates as they become available.
Posted Aug 26, 2025 - 16:18 UTC
This incident affected: Payment Methods (Euro (EUR) - Wire Transfer Deposits).