Basilisk (BSX) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Nov 14, 2022 - 19:47 UTC
Identified
We've identified an issue with the Basilisk (BSX) gateway no longer producing blocks. Deposits and withdrawals are currently delayed, and will resume once the chain begins producing blocks again. We will provide any updates as soon as possible.
Posted Nov 07, 2022 - 20:40 UTC
This incident affected: Digital Currency Funding (Basilisk (BSX)).