Etana Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jun 03, 2021 - 07:04 UTC
Investigating
We're investigating an issue with the Etana funding gateway. Deposits and withdrawals are currently delayed. We will provide any updates as soon as possible.
Posted Jun 03, 2021 - 00:25 UTC
This incident affected: Payment Methods (Etana Custody).