Banking Circle Deposit Delays

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 13:00 UTC

Investigating

We've identified an issue with our Banking Circle funding gateway. Some deposits may be delayed at this time. All other funding methods are operating normally. We are actively working with our funding provider to resolve the issue and will keep you updated.
Posted Apr 21, 2025 - 03:23 UTC