AUD Etana Withdrawal Issue
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Nov 21, 2022 - 20:30 UTC
Identified
This issue has been identified and a fix is being implemented. Please do not initiate an AUD withdrawal until this issue is resolved, as any new or recent AUD Etana withdrawals will be impacted by this issue.
Posted Nov 21, 2022 - 18:58 UTC
This incident affected: Payment Methods (Australian Dollar (AUD) - Domestic).