Issue with card payments using the 'Buy Crypto' button
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Nov 06, 2020 - 20:25 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 06, 2020 - 17:04 UTC
Investigating
We are currently investigating an issue with card payments, which is preventing some clients from using the 'Buy Crypto' tool. We're working towards a solution and will provide any updates as soon as they become available.
Posted Nov 06, 2020 - 15:53 UTC
This incident affected: Website and Kraken Futures (User Interface).