A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2025 - 15:25 UTC
Update
We are continuing to investigate this issue.
Posted Jul 17, 2025 - 12:37 UTC
Update
We have confirmed that the issue affecting deposit crediting now impacts USD-denominated stablecoin deposits (e.g. USDC and USDT) as well as USD across multiple networks.
The issue does not affect withdrawals, and all other systems remain operational. We are continuing to investigate this issue. We will provide an update as soon as we have more information.
Posted Jul 17, 2025 - 12:11 UTC
Investigating
We are currently investigating an issue where USDC deposits on Ethereum, Polygon, Arbitrum, and Solana, and USDT deposits on Solana, Ethereum and Tron are not being credited to user accounts despite appearing as successful.
The issue does not affect withdrawals, and all other systems remain operational.
Our engineering team is actively working to identify the root cause and restore normal deposit crediting behavior. We will provide an update as soon as we have more information.
Posted Jul 17, 2025 - 11:32 UTC
This incident affected: Payment Methods (US Dollar (USD) - Domestic, US Dollar (USD) - Instant, US Dollar (USD) - International) and Digital Currency Funding (Tether USD (USDT) - SPL, Tether USD (USDT) - TRC20, USD Coin (USDC) - ARB, USD Coin (USDC) - ERC20, USD Coin (USDC) - POLY, USD Coin (USDC) - SPL).