Reward Distribution Delay for ETH Restaking

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Nov 29, 2024 - 02:12 UTC

Update

EIGEN's reward distribution has officially started.
Posted Nov 27, 2024 - 11:28 UTC

Update

We are pleased to announce that ETH rewards are currently being paid out, and we anticipate the distribution of EIGEN rewards to commence soon.
Posted Nov 20, 2024 - 10:28 UTC

Update

The initial reward for our ETH restaking is currently pending and will be paid out soon.

We appreciate your patience and will notify you as soon as the distribution is complete.
Posted Nov 14, 2024 - 07:58 UTC

Identified

Please be advised that EigenLayer restaking protocol incorporates an intentional delay of 2 to 3 weeks to ensure the fair distribution of rewards.
As a result, there may be a period before you receive EIGEN / ETH payouts. Additionally, even after you un-stake, you may continue to receive delayed rewards for up to 3 weeks.
Rest assured that as long as your ETH is restaked, you will continue to earn rewards within the quoted APR ranges.
Posted Oct 17, 2024 - 11:14 UTC