BlueOrange Bank (EUR) Deposits
Incident Report for Kraken
Resolved
BlueOrange Bank (EUR) Deposits have been restored.
Posted 2 months ago. Jun 13, 2019 - 12:59 UTC
Investigating
BlueOrange Bank (EUR) Deposits are currently disabled. Our team is investigating the issue and we will provide an update as soon as we have further information.
Posted 3 months ago. Jun 06, 2019 - 07:12 UTC