Flow (FLOW) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jul 29, 2022 - 17:17 UTC
Investigating
We are currently investigating an issue with Flow (FLOW) network. Deposits and withdrawals are currently delayed. We will provide any updates as soon as possible.
Posted Jul 29, 2022 - 16:29 UTC
This incident affected: Digital Currency Funding (Flow (FLOW)).