Open Orders Not Being Displayed - Web & Mobile

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 23:43 UTC

Investigating

We are investigating reports from clients not being able to view open orders on WEB and Mobile Apps. We are working to resolve the issue and will update as soon as we have more information.
Posted Apr 01, 2026 - 23:32 UTC
This incident affected: Website, Kraken App, and Kraken Pro App.