Kraken Wallet APP - Blast Network Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Oct 02, 2024 - 16:54 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 02, 2024 - 10:33 UTC
Investigating
We're currently investigating an issue with the Blast Network on the Kraken Wallet Mobile App. Deposits, withdrawals, transaction history & balances may be delayed and not displayed at this time. All other funding & services on the wallet are operating normally. We are working diligently to resolve the issue and will keep you updated.
Posted Oct 02, 2024 - 10:17 UTC
This incident affected: Kraken Wallet.