USDG Trading Delay

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jun 07, 2026 - 15:30 UTC

Investigating

We are aware of an issue affecting USDG trading pairs. Trades involving USDG are currently unavailable. Our team is working to restore full functionality and we will provide an update once more information is available.
Posted Jun 07, 2026 - 13:51 UTC