Account Access & Withdrawal Issues

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 13:11 UTC

Update

We have implemented a fix and no new users should be impacted. Affected accounts have been restored and should now be accessible.
Our team is now focused on releasing held withdrawals for impacted users. We will provide further updates as remediation continues.
Posted Jun 27, 2025 - 10:15 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 27, 2025 - 09:39 UTC

Investigating

We are investigating reports of clients experiencing account access issues and delayed withdrawals. Our team is actively working to resolve the issue and we will provide updates as soon as more information becomes available.
Posted Jun 27, 2025 - 09:28 UTC
This incident affected: Website and Mobile Applications.