US Domestic Wire Funding Delays
Incident Report for Kraken
Resolved
Domestic USD funding has now been restored.
Posted 11 days ago. Oct 07, 2019 - 13:34 UTC
Identified
We have identified an issue with our US Domestic Wire funding method that is delaying deposits, withdrawals, and also preventing clients from using the US Domestic Wire deposit page. Our team is working to resolve this issue and will update you soon. Thank you for understanding.
Posted 12 days ago. Oct 07, 2019 - 02:52 UTC
This incident affected: Fiat Currency Funding (US Dollar (USD) - Domestic).