Scheduled maintenance is still in progress and will be extended by additional 24 hours. The updated planned completion time is 11 April at 22:00 UTC. We will provide updates as necessary.
Posted Apr 10, 2025 - 12:32 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 09, 2025 - 22:31 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 09, 2025 - 22:27 UTC
Scheduled
The Cardano (ADA) funding gateway will be undergoing maintenance from 22:00 UTC today for approximately 24 hours. Deposits and withdrawals will be unavailable for German Clients Only - transfers made during this time will be processed shortly after the maintenance is complete. We will provide updates as necessary.
Posted Apr 09, 2025 - 22:26 UTC
This scheduled maintenance affected: Digital Currency Funding (Cardano (ADA)).