FLOW Staking / Deposits / Withdrawals

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jan 31, 2021 - 16:28 UTC

Investigating

Deposits, withdrawals & staking activities are currently unavailable for FLOW. Our developers are investigating the issue at this time.
Posted Jan 31, 2021 - 15:07 UTC
This incident affected: Digital Currency Funding (Flow (FLOW)).