Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted May 15, 2024 - 06:39 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 15, 2024 - 06:27 UTC
Investigating
We are aware of a temporary hiccup affecting our funding gateways. Deposits and withdrawals may be delayed at this time. Please be assured that the security and safety of your funds are not affected by this temporary disruption.

We are working diligently to resolve the issue and will keep you informed. Thank you for your patience.
Posted May 15, 2024 - 06:19 UTC